SRCDS Steam group


l4d2 VAC APPROVAL HELP!?!
#1
Ok, so im somewhat of a rookie on servers. but i've done quite a bit of research here lately. and i feel like i've come a long ways. but apparently not quite far enough. so my problem is this. with l4d2 server i host. using external ip. 192.168.1.blah. when i host this way. i get vac approval. BUT! i cannot join my server. i cannot use mm_dedicated to my internal or external ip. i cannot use sv_searchkey. but i can however directly connect to the game. i CAN see it in the steam list and it is vac approved. i CAN see it at the bottom right of my screen as a steam group server. i can join any and every way except through lobby. doesnt matter if i use internal or external ip for mm_dedicated_force_servers.



now, if i host my dedicated server with the command -ip xx.xx.xx.xx then i can connect through lobby. by using the mm_dedicated_force_servers command. it works every time. my friends can join. i have no problems at all. BUT i do not get VAC approved!!!! its so frustrating.



i have all ports forwarded to the correct address. etc. keep in mind the server DOES WORK. i can play on it. my friends can play on it. but something is holding it back from allowing me to get VAC approved??? and yes secure mode is checked everytime. it just doesnt get approved. my router does support NAT loopback. i have a linksys wrt150n router. connected by ethernet. the firmware has been flashed to use DD-wrt firmware. http://www.dd-wrt.com.



some of you will say who gives a $##t about being vac approved?! just play.. blah blah. but i would really like to get this solved. if i get it VAC aprvd then my RCON will work. My friends can see that i am actually in a game. my stats will work. i will be able to use the "add friend from current game" icon. seeing as how none of that crap works when you dont get authed. so all of ye with great minds! solve this plz! haha thanks


IVE ALSO POSTED THIS PROBLEM ON ALLIED MODDERS AND HAVE MADE NO PROGRESS SO FAR. HERES THE LINK TO SEE WHAT ELSE I'VE TRIED.
https://forums.alliedmods.net/showthread.php?t=117662
Reply
#2
Is your server returning a VAC succesfull message when you are starting it?
Slå den med jeres fiberforbindelser...

[Image: 1308107839.png]
Reply
#3
only if i leave off the -ip 75.214.xx.xx command for the startup. if i allow the server to host using the external ip 192.168.1.148 without the -ip 76.214.xx.xx command it will get VAC approved. BUT i cannot join the game from a lobby. only by direct connection. finding it in the steam list or steamgroup list. mm_dedicated_force_servers and sv_search_key do not work from lobby if i host this way. i let it search until it fails and it ends up hosting locally.
Reply
#4
cough... anyone out there?
Reply
#5
Alright, try to run the server WITHOUT -ip argument and add this to your server.cfg
Code:
heartbeat // sends a message to the steam masterservers, that the server is "alive"
Slå den med jeres fiberforbindelser...

[Image: 1308107839.png]
Reply
#6
so i figured it out. using my internal ip i can connect with the command -ip 76.214.xx.xx it works any and everyway that it should but without VAC and steam friends.

now taking off the -ip command would use my external ip 192.168.1.148 and it would get VAC approved. but i couldnt connect from lobby using mm_force_dedicated_servers or the sv_search_key. the reason was because in my server.cfg i was using sv_steamgroup and sv_search_key. apparently you cannot use both of those at the same time in my paticular situation. so i removed just the sv_steamgroup tag from server.cfg and only used sv_search_key. this nailed it spot on.

and apparently using my external ip. i cannot use mm_force_dedicated_server with either ip. external or internal. hope this helps someone else. as this caused me a crap load of trouble.
Reply
#7
When you are on a LAN network, use your internal IP. When you are directly connected to the internet (without any kind of network hardware between), use your external IP
Slå den med jeres fiberforbindelser...

[Image: 1308107839.png]
Reply
#8
yea thats what i was trying to do, but it wouldnt let me. anyways read my previous post. i figured it out already.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)